
Calibrating NI 660x Devices with 
Calibration Executive

This document describes how to load and run the National Instruments 
Calibration Executive procedure for the following NI 660x counter/timer 
devices:

• NI 6601

• NI 6602

• NI 6608
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Conventions
This document uses the following conventions:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames, and extensions.

Equipment and Other Test Requirements
This section describes the equipment, test conditions, documentation, 
and software necessary to calibrate NI 660x counters using Calibration 
Executive.

Test Equipment
Use the following items to calibrate the NI 660x device:

• Highly stable 10 MHz clock source that is accurate to within 
0.75 parts per billion (ppb) for the NI 6608, and accurate to within 
one ppm for the NI 6601/6602. NI recommends a rubidium frequency 
standard clock source.

Note Make sure the source outputs a 10 MHz TTL square wave.

• National Instruments SH68-68-D1 cable (part number 183432-01). 
You must use this cable to calibrate the NI 660x device. 

• SCB-68 breakout box
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Test Conditions
Use the following guidelines to optimize the connections and the 
environment during calibration:

• Keep connections short. Long cables and wires act as antennae, 
picking up extra noise that can affect measurements.

• Use shielded coaxial wire for all cable connections to the device.

• Maintain a temperature of 25 °C.

• Keep the relative humidity below 80%.

• Allow a warm-up time of at least 15 minutes to ensure that the 
measurement circuitry of the NI 660x device and the clock source 
are at a stable operating temperature.

Software
The setup program installs Calibration Executive, as well as the associated 
files listed in Table 1 and Table 2. These tables list the directory path and 
the contents of each file. 

Table 1.  Calibration Executive Directories and Supporting Files for the NI 6601 and NI 6602

Directory Name Contents

Program Files\National Instruments\ 
Calibration Executive\Procedures\
NI6601 NI6602

Directory structure that contains the 
calibration procedure

Program Files\National Instruments\ 
Calibration Executive\Procedures\
NI6601 NI6602\Limits

Microsoft Access databases that store the 
calibration limits

Program Files\National Instruments\

Calibration Executive\Procedures\

NI6601 NI6602\Support Files

Support files, such as bitmaps and DLLs
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Documentation
The following documentation resources are available for download at 
ni.com/manuals:

• Hardware documentation for the NI 660x device

• Calibration Executive Software User Manual

• DAQ Quick Start Guide

• NI-DAQ Function Reference Help

• NI-DAQ User Manual for PC Compatibles

Before Getting Started
The verification procedure for NI 6601/6602 devices takes approximately 
one minute to complete. The calibration procedure for NI 6608 devices 
takes approximately two hours to complete.

For NI 6608 devices, the verification procedure takes approximately 
six minutes, and the adjustment procedure takes approximately 95 minutes. 
During this time, Calibration Executive is not accessible. To terminate 
the adjustment procedure, disconnect the source. Once terminated, the 
adjustment procedure will exit in 20 minutes or less.

Setting Up the PXI-6608 Device in MAX
For calibration, the PXI-6608 device must be in slot 2 of the PXI chassis. 
Complete the following steps to configure MAX to recognize the device as 
being in slot 2:

1. Expand the Devices and Interfaces branch of the MAX 
configuration tree. PXI system controllers that have not yet been 
configured appear as PXI System (Unidentified). Right-click 

Table 2.  Calibration Executive Directories and Supporting Files for the NI 6608

Directory Name Contents

Program Files\National Instruments\ 
Calibration Executive\Procedures\
NI6608

Directory structure that contains the 
calibration procedure

Program Files\National Instruments\ 
Calibration Executive\Procedures\
NI6608\Limits

Microsoft Access databases that store the 
calibration limits

Program Files\National Instruments\

Calibration Executive\Procedures\

NI6608\Support Files

Support files, such as bitmaps and DLLs
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PXI System (Unidentified), and select the appropriate controller 
model from the Identify As menu. For MXI-3 and MXI-4 controllers, 
select External PC.

2. Expand the PXI System controller to display a list of chassis.

3. To identify each chassis, right-click the chassis name, and select the 
appropriate chassis model from the Identify As menu.

4. Verify that MAX lists the PXI-6608 as being in slot 2.

Calibration Executive Procedures
This section explains how to set up and run the Calibration Executive 
procedure.

Setting Up the NI 660x for Calibration
To set up the NI 6601/6602 device for calibration, you must connect it to a 
clock source.

Connecting the NI 6601/6602 to a Clock Source
Complete the following steps to connect the NI 6601/6602 to an alternative 
clock source:

1. Use the SH68-68-D1 cable to connect the NI 6601/6602 device to the 
68-pin breakout box.

2. Using twisted-pair wires, connect the clock to source pins 7 and 41 
on the 68-pin breakout box. Pin 7 corresponds to PFI_35, which is 
the SOURCE of counter 1 on all NI 6601/6602 devices. Pin 41 is the 
digital ground.

Connecting the NI 6608 to a Clock Source 

Note Before running the NI 6608 procedures, close all other programs, and verify that the 
PXI-6608 device is in slot 2 and that MAX is configured to recognize the device as being 
in slot 2. For information about configuring MAX, refer to the Setting Up the PXI-6608 
Device in MAX section of this document.

Complete the following steps to connect the NI 6608 to an alternative clock 
source:

1. Use the SH68-68-D1 cable to connect the NI 6608 to the 68-pin 
breakout box.

2. Connect the clock source to pin 2 (PFI_39). PFI_39 is the SOURCE 
of counter 0 on the NI 6608.

3. Connect the ground of the clock source to pin 36.
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Loading and Running the Calibration Executive Procedure
Complete the following steps to load and run the NI 660x Calibration 
Executive procedure:

1. Launch Calibration Executive.

2. Follow the Calibration Configuration Wizard to load the NI 660x 
calibration procedure. 

Note For more information about loading and running the calibration procedure, refer to 
the Calibration Executive Software User Manual.

3. When prompted to enter information about the device, enter the device 
number Measurement & Automation Explorer (MAX) assigned to the 
counter.

4. When the correct procedure loads, click Run Procedure.

5. Follow the Calibration Executive instructions.

If the NI 6608 fails after calibration, refer to the Troubleshooting section of 
this document. If the NI 6608 fails after troubleshooting, return it to NI for 
repair or replacement.

NI 6601/6602 devices that fail verification cannot be adjusted and must be 
returned to National Instruments for repair or replacement.

Viewing the Calibration Report
When the calibration procedure is finished, complete the following steps to 
view the calibration report:

1. Select View»Reports.

2. Click View. 

Modifying the Font Size in a Calibration Report
If you selected an HTML format and the text size in the calibration report 
is too large, you can decrease the size as follows:

• In Internet Explorer, modify the text size by selecting View»Text Size.

• In Netscape, modify the text size by selecting View»Decrease Font.
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Troubleshooting
This section describes how to correct NI 660x calibration problems. 

Use the following troubleshooting guidelines if the NI 660x device fails 
after running the calibration procedure:

1. Verify that the clock source is a 10 MHz TTL signal.

2. Check that the device is properly connected, and run the Calibration 
Executive procedure again.

3. If the calibration fails after running the Calibration Procedure again, 
open the test panel in MAX and configure as follows:

• Counter Mode: Simple Event Counting

• Counter: GPCTR0

• Event Source: Counter Source Pin

An increasing Counter Value indicates that the device is connected 
properly. A counter value that does not change indicates that the signal 
is not connected or is not working.

If the NI 660x device fails after completing these steps, contact NI for 
repair or replacement.

Note You can use Microsoft Access 2000 or later to modify the database containing 
the test results. By default, this database is located in \Calibration Executive\ 
Databases\Calibration Reports.mdb.

Errors
This section describes some of the errors that can occur when calibrating 
an NI 660x device.

Error Code –15
Error code –15 occurs at the beginning of the calibration procedure if the 
computer is configured to use commas as decimal places. Calibration 
Executive only supports using periods for decimal places.

To correct this error, change the computer configuration. After running 
the Calibration Executive, change the computer configuration back to 
the default settings.
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Windows 2000/NT/XP Users
To change the computer configuration in the Windows 2000/NT/XP 
operating system, complete the following steps:

1. Open the Control Panel.

2. Click Date, Time, Language, and Regional Options, and select 
Regional and Language Options.

3. Click Customize.

4. Change the Decimal symbol from a comma to a period, and change 
the Digit grouping symbol from a period to a comma.

Note After completing the calibration procedure, remember to change the computer 
configuration back to its original settings.

For more information about error codes, refer to the Status Codes section 
of the NI-DAQ Function Reference Help. To access this file, select Start» 
Programs»National Instruments»NI-DAQ»Traditional NI-DAQ 
Function Reference Help.

Specifications
The NI 660x data sheets are available for download at ni.com/products.

Specification information is available in the following documents:

• NI 6601/6602 Specifications

• Device specifications listed in About Your 6608 Device Note to Users

• NI 6608 Timing I/O Device Calibration Procedure

Technical Support Resources

NI Web Support
National Instruments Web support is your first stop for help in solving 
installation, configuration, and application problems and questions. Online 
problem-solving and diagnostic resources include frequently asked 
questions, knowledge bases, product-specific troubleshooting wizards, 
manuals, drivers, software updates, and more. Web support is available 
through the Technical Support section of ni.com.

A Declaration of Conformity (DoC) is our claim of compliance with the 
Council of the European Communities using the manufacturer’s 
declaration of conformity. This system affords the user protection for 
electronic compatibility (EMC) and product safety. You can obtain the DoC 
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for your product by visiting ni.com/hardref.nsf. If your product 
supports calibration, you can obtain the calibration certificate for your 
product at ni.com/calibration.

Worldwide Support
National Instruments corporate headquarters is located at 
11500 North Mopac Expressway, Austin, Texas, 78759-3504. 
National Instruments also has offices located around the world to help 
address your support needs. You can access our branch office Web sites 
from the Worldwide Offices section of ni.com. Branch office Web sites 
provide up-to-date contact information, support phone numbers, email 
addresses, and current events. 

If you have searched the technical support resources on our Web site 
and still cannot find the answers you need, contact your local office or 
National Instruments corporate. For telephone support in the United States, 
dial 512 795 8248. For telephone support outside the United States, contact 
your local branch office: 

Australia 1800 300 800, Austria 43 0 662 45 79 90 0, 
Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599, 
Canada (Calgary) 403 274 9391, Canada (Ottawa) 613 233 5949, 
Canada (Québec) 450 510 3055, Canada (Toronto) 905 785 0085, 
Canada (Vancouver) 514 685 7530, China 86 21 6555 7838, 
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 
Finland 385 0 9 725 725 11, France 33 0 1 48 14 24 24, 
Germany 49 0 89 741 31 30, Greece 30 2 10 42 96 427, 
India 91 80 51190000, Israel 972 0 3 6393737, Italy 39 02 413091, 
Japan 81 3 5472 2970, Korea 82 02 3451 3400, Malaysia 603 9131 0918, 
Mexico 001 800 010 0793, Netherlands 31 0 348 433 466, 
New Zealand 0800 553 322, Norway 47 0 66 90 76 60, 
Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 095 783 68 51, 
Singapore 65 6226 5886, Slovenia 386 3 425 4200, 
South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 
Sweden 46 0 8 587 895 00, Switzerland 41 56 200 51 51, 
Taiwan 886 2 2528 7227, Thailand 662 992 7519, 
United Kingdom 44 0 1635 523545
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